Installation Prerequisites

Installing and using Clawpack requires the following:

Operating system

  • Linux
  • Mac OS X: For the Fortran packages, you need to have the Xcode developer tools installed in order to have make working. PyClaw does not require make.

Fortran

PyClaw can now be installed without a Fortran compiler; see Using conda (does not require a Fortran compiler).

To use the other packages, you will need gfortran or another F90 compiler

See Fortran Compilers for more about which compilers work well with Clawpack.

Python

  • Python Version 2.7 or above, or (new in 5.4.0) Python 3
  • NumPy (for PyClaw/VisClaw)
  • matplotlib (for PyClaw/VisClaw)

The Anaconda Python Distribution is an easy way to get all of these. See Python Hints for more information on installing the required modules and to get started using Python if you are not familiar with it.

pip

If you are installing via pip install then you need pip. You may already have it; in particular the Anaconda Python distribution contains pip. If you need to install it, see https://pip.pypa.io/en/stable/installing/

The version of pip install suggested for Quick Installation of all packages requires a recent version of pip, so you may need to upgrade if you run into problems.

Git

If you are installing via pip using the command in Quick Installation of all packages, or via git clone, then you need Git. You may already have it; in particular the Xcode tools on Mac OSX contains Git. If you need to install it, see the Git book.